Slow response times
Incident Report for IllumiDesk
Resolved
We have finished adding additional capacity and systems are operating normally. Thank you.
Posted Apr 24, 2019 - 11:30 EDT
Identified
Our systems have experienced unexpected CPU load in our Pilot environment. We will add more capacity to resolve the issue.
Posted Apr 24, 2019 - 10:41 EDT